Yarn 1.0, Angular-cli 1.4 & React License Troubles

Hello,
Two special good news this week: the release of Yarn 1.0 and Angular-cli 1.4.
  • Workspaces in order to handle mono-repos properly.

 

  • “–” option prefix is not needed anymore to pass parameters to your yarn commands: `yarn e2e –specs=test/e2e/….spec.ts`
  • Who’s using yarn without encountering conflicts on the yarn.lock file and then overwriting the file using yarn install. Now, you just have to solve conflicts in package.json then run the yarn command to automagically fix the conflict in the yarn.lock file.
  • Big news: “schematics”. Doesn’t seem to be documented yet but it seems that we will soon be able to customize the way `ng new` and `ng generate` work. Not that crazy but really useful.
React License Issues
  • Since 2016, Facebook is distributing React with a BSD + Patents license. I am not a lawyer but if you are using React in your products, you can’t sue Facebook for anything.

 

  • These licenses are now part of the Apache Software Foundation X Category. React-based developments will not be allowed to be part of ASF products.

 

  • Facebook doesn’t want to rollback.
  • It’s not criticism of React but once again, I recommend  library/framework agnostic development. Your code must be the less bound to the library/framework as possible. That way, you can migrate easily from a technology to another.

 

Younes

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s